求助 vs studio更新后 无法通过编译

0

错误输出:

1>EasyXw.lib(Image.obj) : error LNK2038: 检测到“_ITERATOR_DEBUG_LEVEL”的不匹配项: 值“0”不匹配值“2”(Ammo.obj 中)
1>EasyXw.lib(Image.obj) : error LNK2038: 检测到“RuntimeLibrary”的不匹配项: 值“MT_StaticRelease”不匹配值“MDd_DynamicDebug”(Ammo.obj 中)
1>EasyXw.lib(EasyX.DrawOnImg.obj) : error LNK2038: 检测到“_ITERATOR_DEBUG_LEVEL”的不匹配项: 值“0”不匹配值“2”(Ammo.obj 中)
1>EasyXw.lib(EasyX.DrawOnImg.obj) : error LNK2038: 检测到“RuntimeLibrary”的不匹配项: 值“MT_StaticRelease”不匹配值“MDd_DynamicDebug”(Ammo.obj 中)
1>D:\桌面\Code\C++\Project\Project1\x64\Debug\Project1.exe : fatal error LNK1319: 检测到 4 个不匹配项

vs studio更新后未更改任何配置,出现以上错误,卸载重装不能解决问题,将所有代码全部复制到新工程后仍不能解决,参照网上的教程也不能解决。

ava
FishLXY

2020-7-18

0

如果你使用的是刚刚下载的 EasyX_20200718,请先用 EasyX_20200718 的安装程序卸载,并重新下载 EasyX_20200520 版本。刚发布的版本有问题,已经被撤回。

ava
慢羊羊

2020-7-18

非常感谢! - FishLXY 2020-7-18
问题已解决 - FishLXY 2020-7-18